Announcement

Collapse
No announcement yet.

Error: Could not allocate vin => when starting masternodes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error: Could not allocate vin => when starting masternodes

    I made two transactions for the masternode collateral. After waiting for some confirmations and going to the debug console i get 2 txids as expected. I use them to create the strings for the masternode.conf file. After restarting the wallet, with the new masternode.conf, i'm trying to start the masternodes but get the error "Could not allocate vin". Going to the debug console i get no masternode outputs anymore (hence it cant allocate the TXID for the collateral). After removing the strings (or placing # in front of them) from the masternode.conf and restarting the wallet, i get the two masternode outputs in debug console again as before.

    ➡️What do you think might have caused the bug?
    I have not a clue :-)
    ➡️What steps did you do to cause the bug, in other words, what actions did you perform up and until the point where the bug happened?
    Just added the strings to the masternode.conf file and restarted
    ➡️Has the bug occured before, and were you able to restart, or do something else to make it go away before it became persistent?
    Just restarted the wallet after adjusting the masternode.conf
    ➡️What version of the wallet are you running?
    Windows QT 64 bit.
    ➡️Was your wallet fully synched when it happened?
    Yes.
    ➡️Did you close your computer while the wallet was running?
    No.
    ➡️Did you close your wallet before it was fully synched?
    No.
    ➡️Please provide any other details which may be relevant for our developers so they can replicate the bug themselves and squash it!
    See above.

  • #2
    Originally posted by w00dstuck View Post
    I made two transactions for the masternode collateral. After waiting for some confirmations and going to the debug console i get 2 txids as expected. I use them to create the strings for the masternode.conf file. After restarting the wallet, with the new masternode.conf, i'm trying to start the masternodes but get the error "Could not allocate vin". Going to the debug console i get no masternode outputs anymore (hence it cant allocate the TXID for the collateral). After removing the strings (or placing # in front of them) from the masternode.conf and restarting the wallet, i get the two masternode outputs in debug console again as before.

    ➡️What do you think might have caused the bug?
    I have not a clue :-)
    ➡️What steps did you do to cause the bug, in other words, what actions did you perform up and until the point where the bug happened?
    Just added the strings to the masternode.conf file and restarted
    ➡️Has the bug occured before, and were you able to restart, or do something else to make it go away before it became persistent?
    Just restarted the wallet after adjusting the masternode.conf
    ➡️What version of the wallet are you running?
    Windows QT 64 bit.
    ➡️Was your wallet fully synched when it happened?
    Yes.
    ➡️Did you close your computer while the wallet was running?
    No.
    ➡️Did you close your wallet before it was fully synched?
    No.
    ➡️Please provide any other details which may be relevant for our developers so they can replicate the bug themselves and squash it!
    See above.
    Head to the github and download the latest version of the wallet. You can check this in the Debug Console, under the "Information" tab. The version should read 1.0.0. If it does not, then get the latest version. As a note, version 1.0.1 should be released soon as well.

    Comment


    • #3
      I have this same bug, I do not know the version of my wallet, but tonight I will check and try to start the MNs with the version from github. I thought that there was only one version of the wallet at this moment, because when the wallet was launched, I get it from the website link.

      Comment


      • #4
        Originally posted by w00dstuck View Post
        I made two transactions for the masternode collateral. After waiting for some confirmations and going to the debug console i get 2 txids as expected. I use them to create the strings for the masternode.conf file. After restarting the wallet, with the new masternode.conf, i'm trying to start the masternodes but get the error "Could not allocate vin". Going to the debug console i get no masternode outputs anymore (hence it cant allocate the TXID for the collateral). After removing the strings (or placing # in front of them) from the masternode.conf and restarting the wallet, i get the two masternode outputs in debug console again as before.

        ➡️What do you think might have caused the bug?
        I have not a clue :-)
        ➡️What steps did you do to cause the bug, in other words, what actions did you perform up and until the point where the bug happened?
        Just added the strings to the masternode.conf file and restarted
        ➡️Has the bug occured before, and were you able to restart, or do something else to make it go away before it became persistent?
        Just restarted the wallet after adjusting the masternode.conf
        ➡️What version of the wallet are you running?
        Windows QT 64 bit.
        ➡️Was your wallet fully synched when it happened?
        Yes.
        ➡️Did you close your computer while the wallet was running?
        No.
        ➡️Did you close your wallet before it was fully synched?
        No.
        ➡️Please provide any other details which may be relevant for our developers so they can replicate the bug themselves and squash it!
        See above.
        I had this issue and what I did was check masternode outputs in console, you will see the txid that you have to use; take the txid, create one masternode genkey for each txid of masternode outputs. Now use this pair to build your masternode.

        If you do not see any masternode outputs, send 1M coind to yourself and try to build the maternode. It will be much probably that everything is going to be right.

        Comment

        Working...
        X