Announcement

Collapse
No announcement yet.

VPS Ubuntu 18.04 dependencies

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • VPS Ubuntu 18.04 dependencies

    sudo add-apt-repository ppa:bitcoin/bitcoin -y
    sudo apt update sudo apt install libdb4.8-dev libdb4.8++-dev libevent-dev libminiupnpc-dev libqrencode-dev -y
    sudo apt install libboost-all-dev libzmq3-dev -y

  • #2
    Can I use 16.04?

    Comment


    • daps_spain
      daps_spain commented
      Editing a comment
      No problem, you can use it

    • KINGer_C
      KINGer_C commented
      Editing a comment
      Thank you very much!

  • #3
    Hi daps_spain
    Here is the dependency list that Arcadia uses during our deployments. It might be useful for anyone going the full nine yards:
    apt-get update && \
    apt-get install software-properties-common -y --fix-missing && \
    add-apt-repository ppa:bitcoin/bitcoin -y && \
    apt-get update && \
    apt-get install libminiupnpc-dev libevent-dev libzmq3-dev libboost-all-dev libdb4.8++-dev libdb4.8-dev libssl1.0-dev nano -y --fix-missing && \
    &
    RUN apt-get update && \
    apt-get install build-essential libtool autotools-dev automake pkg-config bsdmainutils curl wget nsis libevent-dev python-setuptools patch -y --fix-missing
    POA MINER:
    RUN apt-get install libcurl4-openssl-dev libjansson-dev -y --fix-missing

    Comment

    Working...
    X